Symptoms
After having started the MS Word UI of DTM, the Desktop is shown, instead of the iSeries contents.
Cause
The hostname of the iSeries is not known by the client PC
NetServer access is not allowed
Solution
1. Add iSeries host to DNS or windows hosts file
Ping the hostname of the iSeries. The hostname and a q-prepended hostname should be known by the client computer. E.g.: if the hostname of the iSeries is STESTSYS, then STESTSYS and QSTESTSYS should be known by the client computer.
There are two possibilities: If the problem exists on all other clients, this is a DNS server issue and can better be solved by adding DNS entries.
In most cases, only one computer cannot access the iSeries, so the hostnames need to be added in the windows hosts file.
Open the file C:\Windows\System32\drivers\etc\hosts
Then, add two lines:
first one: <ip address of the iSeries server> <spaces or tab> <hostname of the server>
second: <ip address of iSeries server> <spaces or tab> <hostname of the server, prepended by a q>
example:
111.111.111.1 STESTSYS
111.111.111.1 QSTESTSYS
To test whether this works, open a new CMD and ping the server name as well as the q-prepended server name.
2. Netserver permissions
Open up the iSeries (Operations) Navigator and open up the iSeries to which the connection fails.
On the left hand side, open up Network > Servers > TCP/IP then at your right hand side, right click on iSeries NetServer (or AS400 Netserver, depending on the version, it is called differently) and choose properties. The option 'Allow iSeries Netserver access using the system name' is set to NO. This has to be changed to YES.